Rev Dj RaZorslave (razorslave) wrote,
Rev Dj RaZorslave
razorslave

TiBook. . .

Apparently, either the PRAM is dead or lacking a charge entirely, I've been unable to find definate information on a fix, I did however stumble on this section of a forum whose proprietor just seemps to want people to buy parts form him for help. . .


http://www.powerbookmedic.com/forum/viewtopic.php?t=1582 it seems to exactly describe the problem and what he did to fix it, I've found the downloadable dissasembly pdf so I think I may give it a try. . .

Quoted from Link:
=====================
his model M5884 was working great until a year of storage. Now nothing. No lights on power adapter puck, no lights on laptop or battery. Tried removing battery, pressing reset on back and then pushing power button but all still dead. Took apart and disconnected cables from PMU battery and all dead.

So... should there be a light on the puck? Any easy way to test it or the logic board to see if voltage is getting trough? Is it 24V AC or DC?

Should there be any lights on the laptop around the power button?
Should the battery LEDs be lit?
Would a drained PMU battery (part 616-0114-A) cause the laptop to act dead?
Would a failed hard drive cauise this problem?
Any suggestions?
-------------------------------------
HOLD ON... CAN'T BELIEVE IT
after hooking the PMU connections back up (all but to the PMU battery and DVD still removed) it Started and came completely back to health except date set very wrong. This totally confirms posting on another site (author was "paco53") that suggests only way to resolve this storage-related startup problem is to isolate the PMU and/or PMU battery for a little while and then hook back up. Very odd but it worked !!!

==============================================

Rev
Subscribe
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 7 comments