?

Log in

No account? Create an account

Previous Entry | Next Entry

TiBook. . .

Apparently, either the PRAM is dead or lacking a charge entirely, I've been unable to find definate information on a fix, I did however stumble on this section of a forum whose proprietor just seemps to want people to buy parts form him for help. . .


http://www.powerbookmedic.com/forum/viewtopic.php?t=1582 it seems to exactly describe the problem and what he did to fix it, I've found the downloadable dissasembly pdf so I think I may give it a try. . .

Quoted from Link:
=====================
his model M5884 was working great until a year of storage. Now nothing. No lights on power adapter puck, no lights on laptop or battery. Tried removing battery, pressing reset on back and then pushing power button but all still dead. Took apart and disconnected cables from PMU battery and all dead.

So... should there be a light on the puck? Any easy way to test it or the logic board to see if voltage is getting trough? Is it 24V AC or DC?

Should there be any lights on the laptop around the power button?
Should the battery LEDs be lit?
Would a drained PMU battery (part 616-0114-A) cause the laptop to act dead?
Would a failed hard drive cauise this problem?
Any suggestions?
-------------------------------------
HOLD ON... CAN'T BELIEVE IT
after hooking the PMU connections back up (all but to the PMU battery and DVD still removed) it Started and came completely back to health except date set very wrong. This totally confirms posting on another site (author was "paco53") that suggests only way to resolve this storage-related startup problem is to isolate the PMU and/or PMU battery for a little while and then hook back up. Very odd but it worked !!!

==============================================

Rev

Comments

( 7 comments — Leave a comment )
tenebras23
May. 23rd, 2007 03:34 pm (UTC)
Gotta love PRAM
Just as much fun as a dead CMOS battery or a corrupt swap file.
razorslave
May. 23rd, 2007 03:51 pm (UTC)
Re: Gotta love PRAM
no I know PC Hardware, a CMOS battery is intentionally EASY to change, and replace, it will also not keep a machine from posting, just keeping any of the data stored in the CMOS from being stored and a corrupt swap file will not prevent your from posting.

The PRAM Battery has to be Soldered in and out

It's a royal P.I.T.A.

Rev
tenebras23
May. 23rd, 2007 04:04 pm (UTC)
Re: Gotta love PRAM
Oh fun with a soldering iron, even better :(
daq42
May. 23rd, 2007 04:57 pm (UTC)
http://docs.info.apple.com/article.html?artnum=14449#faq8

You know you don't have to desolder the PRAM battery, right? The "reset button" on the back of the unit disconnects the PRAM circuit and allows the power management unit to reset. You should have called me instead of texting...
razorslave
May. 23rd, 2007 06:50 pm (UTC)
Yeah, I tried the reset button, it didnt work, I was going to see if I could have you take a look at it, as you work with those things all day long. . .

I didnt call cuz it was after 11:00pm and I didn't think you'd be awake. . .

Rev
(Deleted comment)
razorslave
May. 23rd, 2007 06:49 pm (UTC)
no, that quoted section of text was the post from the forum, it's still not working. . .

Rev
(Deleted comment)
razorslave
May. 23rd, 2007 06:59 pm (UTC)
Jim and I are going to take a look at it tonight. . . see what we can figure out.

Rev
( 7 comments — Leave a comment )